Docker Patches 5-Year-Old Critical Vulnerability After Resurfacing in Later Versions

Docker has issued security updates to address a critical vulnerability impacting certain versions of Docker Engine that could allow attackers to bypass authorization plugins (AuthZ) and potentially escalate privileges. This flaw, tracked as CVE-2024-41110, which received a CVSS score of 10/10, was originally discovered and fixed in Docker Engine v18.09.1 in 2019, but it resurfaced in later versions that were discovered in April 2024. The five (5) year old vulnerability allows attackers to exploit a specific condition where an API request with a Content-Length of zero (0) bypasses the usual body checks, causing the AuthZ plugin to potentially approve unauthorized actions. This issue affects Docker Engine versions up to v27.1.0, especially for users relying on AuthZ for access control. While Docker Desktop versions up to 4.32.0 are also affected, the risk is limited, as exploitation requires local access to the Docker API. A fix is anticipated in the upcoming Docker Desktop v4.33. This issue, along with other vulnerabilities addressed by Docker, underscores the importance of keeping container environments secure and up-to-date. CTIX analysts recommend users follow the guidance from Docker and upgrade to the latest versions or disable AuthZ plugins and restrict API access to mitigate the risk of exploitation.